Problema de compilación Teamviewer9 desde AUR (Manjaro)

Para solucionar este inconveniente, solo hay que editar el PKGBUILD, designar el editor necesario para valga la redundancia editar el archivo, a continuación el archivo posteado en pastebin por los mantenedores/contribuidores:

# Maintainer: Hilinus
# Contributor: Alucryd pkgname=teamviewer
pkgver=9.0.27891
pkgrel=1
pkgdesc=”All-In-One Software for Remote Support and Online Meetings”
arch=(‘i686’ ‘x86_64’)
url=”http://www.teamviewer.com”
license=(‘custom’)
depends=(‘bash’)
install=${pkgname}.install

          if [[ $CARCH == ‘i686’ ]]; then

source=(“teamviewer_linux-${pkgver}.deb::http://www.teamviewer.com/download/teamviewer_linux.deb”)
md5sums=(‘2ecb377b655cebe417c4ccaf2eff1359’)
depends+=(‘alsa-lib’ ‘gcc-libs’ ‘libxdamage’ ‘libxtst’ ‘zlib’ ‘freetype2’)
elif [[ $CARCH == ‘x86_64’ ]]; then
source=(“teamviewer_linux_x64-${pkgver}.deb::http://www.teamviewer.com/download/teamviewer_linux_x64.deb”)
md5sums=(’35ba2b46fe7d2669bfc8e67e8243694d’)
depends+=(‘lib32-gcc-libs’ ‘lib32-alsa-lib’ ‘lib32-libxtst’ ‘lib32-libxdamage’ ‘lib32-zlib’ ‘lib32-freetype2’)

          fi

build() {
cd “${srcdir}”
tar -xf data.tar.gz
}

          package() {

cd “${srcdir}” 

# Install

           cp -dr –no-preserve=ownership {etc,opt,usr,var} “${pkgdir}”/

          # Additional files

rm “${pkgdir}”/opt/teamviewer9/tv_bin/xdg-utils/xdg-email
install -dm 755 “${pkgdir}”/usr/{lib/systemd/system,share/applications,share/licenses/teamviewer}
install -m 644 “${pkgdir}”/opt/teamviewer9/tv_bin/script/teamviewerd.service “${pkgdir}”/usr/lib/systemd/system/teamviewerd.service
ln -s /opt/teamviewer9/tv_bin/desktop/teamviewer-teamviewer9.desktop “${pkgdir}”/usr/share/applications/teamviewer.desktop
ln -s /opt/teamviewer9/License.txt “${pkgdir}”/usr/share/licenses/teamviewer/LICENSE
}

Solo basta cambiar estas tres lineas resaltadas, el pkgver: versión del paquete y las md5sums: que es el hash MD5 para ver la integridad del archivo en este caso para el paquete de 32 bits o 64 bits, pero si el  pkgver=9.0.27891 ya es igual con respecto al suyo, ya no habrá inconvenientes y puede salir del editor; ya ha sido subsanado el error y el paquete esta actualizado.

Hasta otro post, buenas vibras lectores.

Anuncios

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s